Airport CEO Alpha 28.6 Released


#103

Perfect, bug number?


#104

Next time it happens I will resubmit, on current loads i have not seen it for a while.


#105

@Olof, I have a thought on the check-in desk issue. I noticed I received it on a larger airport, and we know with larger airports, at this point, delays are inevitable. Is it possible that there may be so many delays associated with 1 baggage bay that it is throwing everything off with check-in desk allocations?


#106

I just sent you a new report: ACEO-7360

I did check one of the flights causing this error message and couldn’t find a reason for it (*). I did describe it in the bug report. The savegame itself is from an older version of the game, while all check-in desks had been re-build and all flights had been cancelled (closing and re-opening every stand) and newly assigned by the auto scheduler in the recent version.

(*) … have to edit/add, two check-in desks are assigned to the same flight, so that could be why there’s none available for the third flight. Still don’t know if auto scheduler should be able to consider this in this version of the game.


#107

i managed to get less notifications by getting more people to arrive faster at the airport, checkins tend to stay open untill the Bus is loaded up, occupying a checkin slot.


#108

ACEO-7363 I am still having issue where a/c will enter from one side, cross over to the entrance just opposite of it, do a U-turn, then enter the runway; very unrealistic. If I set the entrances/exits up to specifically be entrance/exit ONLY it then messes up the aircraft pathfinding process, and the planes won’t depart their stand (save and reload barely temporarily fixes for about 10-15 min.) HOWEVER, if I set ALL entrances/exits to be both an exit and an entrance, it fixes everything, BUT my aircraft now do a big loop around the runway before entering and departing.

This is an airport I started last night; so this is a fresh build in Alpha 28.5-0


#110

Well… @Olof , as I wrote:

that implicates, that it is practically working correctly. :wink:

I have doublechecked all connections at least twice, everything is fine. flights on same stand are serviced correctly, only incident report is wrong…


#111

rebuilt bug and sent a new report: ACEO-7368


#112

and still no reply about my crashed saves…
could you please make the bug reports visible in Jira?


#113

We work after a basis that the more issues we have around a certain bug type the more prioritized it is, right now there are very few save crash issues so they get down prioritized. Issues are only visible in Jira after (and if) we’ve processed them.


#114

Alpha 28.6 is out (on experimental). Only what’s mentioned in the change log below has been fixed, still investigation many of the issues discussed in this topic. New update will be deployed tomorrow! :slight_smile:

    Release notes - Airport CEO - Version Alpha 28.6-0

Improvement

  • [ACEO-7238] - Ability to open runway with only one runway entrance if runway is set to arrival or departure and runway entrance is set to both (due to stand connectivity)
  • [ACEO-7352] - Conveyor belt automatically spawn staff zone underneath
  • [ACEO-7356] - Conveyor belt animation speed set by time speed of game
  • [ACEO-7369] - Tree animation using shaders

Bug

  • [ACEO-2729] - Missing conveyor belt rotation switch cases causes incorrect sprite rotation for placed conveyor belts
  • [ACEO-7013] - Replacing runway exit can get flight stuck on runway
  • [ACEO-7165] - Runway extension causes UI overlays to go the wrong way
  • [ACEO-7256] - Incorrect validation for ramp agents onboard service cars when leaving a small stand can cause service car deadlock
  • [ACEO-7269] - Aircraft can in rare cases not execute runway entrance path-finding if stand settings changes at same time
  • [ACEO-7273] - Grass runway entry not setting one way access properly
  • [ACEO-7313] - Rare NullReferenceException issue can cause aircraft to stop arriving
  • [ACEO-7318] - Crosswalk displayment inconsistencies for small remote stands
  • [ACEO-7348] - Airside shuttle bus stop and service car stop doesn't automatically zone as secure
  • [ACEO-7370] - Objects that are colorable are also automatically clickable rendering nothing but an empty selection image
  • [ACEO-7371] - Color picker panel incorrectly placed when re-coloring objects in the placeable panel view

New Feature

  • [ACEO-7351] - Colorable conveyor belts
  • [ACEO-7353] - Right-click interactable conveyor belts

#115

Still having ramp agents get stuck on previous update, will check on this one


#116

Conveyor belt automatically spawn staff zone underneath

Does “removing” a conveyor belt, automatically remove staff zone? Else when rebuilding an terminal you will have stripes of staff zone all over.


#117

Just did a test … overground belts do get their staff zones beneath, but removing the belts doesn’t remove the zone automatically too. Doesn’t matter if using the “bulldozer” or using “belt-placing with [ctrl]”-method.

edit: overground-underground-transition blocks don’t get a staff zone beneath, as they are placed as underground block (orange arrow), even though they get converted to an overground block (green arrow).
Sometimes some of the overground belts miss their staff zone too. Reported as ACEO-7831.


#118

You can just de-zone them. After deletion


#119

Of course you can. Being able to de-zone large areas that’s even quite easy. I understand jasperwillens question though, as it’s an additional step you need to do in non-staff areas. On the other hand, it would be an additional step to re-zone in staff areas. It’s a question of which way to prefer.

Personally I’m fine as it is now, as most complex overground conveyor systems (scanners,…) are part of the staff area anyway.


#120

Thanks for the update! Did some testing on some points.

Very nice that we can colour overground conveyor belts now :heart_eyes_cat:, but without a multi selection option it’s ‘finger clicking bad’ if you want to change an existing conveyor belts colour. So for now it’s better to re-built a conveyor belt in a selected colour.

For the people who are not familiar with colouring yet, in the built menu you can set the new default colour for a buildable object.

  • [ACEO-7353 ] - Right-click interactable conveyor belts

This works for all parts, so cleaning will be done, repair (don’t know yet if it will actually get dirty or broken), naming per belt piece and even to the point that you can (in)activate a single belt piece :grin:

  • [ACEO-2729] - Missing conveyor belt rotation switch cases causes incorrect sprite rotation for placed conveyor belts

Don’t know if this is directly related, but when you built a overground conveyor belt when paused it looks a bit strange on the corners, when back to a speed the belt functions normal and the arrows are correct again as well

  • [ACEO-7352] - Conveyor belt automatically spawn staff zone underneath

This works, but not when only 1 belt piece is placed between corners

  • [ACEO-7273] - Grass runway entry not setting one way access properly

In combination with ACEO-7238 it does work for exiting the runway, but not when set to entrance only.

  • [ACEO-7013] - Replacing runway exit can get flight stuck on runway - Works :+1:
  • [ACEO-7238] - Ability to open runway with only one runway entrance if runway is set to arrival or departure and runway entrance is set to both (due to stand connectivity) - Works :+1:

Found a new small bug, the animation of the fuel truck re-fueling the plane or re-fueling the truck at the fuel depot is not working.
Edit: This is working, but if the time is set to 2x or 3x the speed you cannot see the arrows moving :blush:


#121

image

Finalllllyyyyyyyyyy we can build these conveyor belts!


#122

Finalllllyyyyyyyyyy we can build these conveyor belts!

Ahh finally my OCD will be cured :stuck_out_tongue: can’t wait to test tonight.


#123

Indeed very cool! You can built some funny stuff with it