Airport CEO Alpha 32 Released (The Turnaround Update)

@Alexander i believe this one’s for you.

1 Like

Some Alpha 33 keys slipped through… an update will be out shortly to fix this! :wink:


New update rolling out now, immediately to be pushed to default. No new number, just a regular hotfix.


Well, still a fan :grinning:


BUG: When placing an item during an autosave, the game will deselect the item and the placed item will have a green box until game restart.


I’ve seen this too, but I don’t have autosave on. I have been using debug with simulate construction off though, and it seemed to also happen after copying blueprint with queues. Then it randomly happens when placing anything else.


I’m on the default branch 1.32 and my screen just stays on the loading screen saying almost done for a long time, restart many times and tried different saves. @Olof?

Same with me

  • I just saw 18 people stuff themselves in a taxi. I thought that was fixed :thinking:
  • I think I saw the old save prompt pop up when I quit the game.

EDIT 01:

Default Alpha 32.12-0

1 Like

@EvanTheCEO, did you create a bug report of that? Sounds like an exception was thrown and I need to see the log file for that one.

@Jas, I need to check out your save files. Both you and @fabiopinto can send them immediately to us at! :slight_smile:

The taxi problem is obviously not fixed, needs more unforgiving code…

1 Like

lol good luck! :smiley:

1 Like

I’ve found the issue for the loading problem. An update will be out on the experimental branch later tonight!


Would this fix my issue? Fingers crossed

Sorry, update is pushed until tomorrow.

1 Like

Olof, has the update been pushed

not yet so i think devs are busy but i am sure they will push out the update


Good evening! A bit delayed, but here’s this weeks update for Alpha 32 on the experimental branch. We’ve fix a few critical loading problems and have added additional logging for a few save problems we’re detecting via the bug reporting tool, the extended logging is basically the game saving and including the logs of your three last plays on that specific save so that we can see what happened to your game when you saved it (today we only get the log from the current session).

We’ve also added an interval for auto saving and made it game time agnostic, so that if you build on pause the game will not finally auto save as expected! :slight_smile:

    Release notes - Airport CEO - Version Alpha 32.12-1


  • [ACEO-17324] - Persistent logging implemented to better detect potential saving issues


  • [ACEO-17176] - Copying and pasting objects can in some instances throw null reference exceptions
  • [ACEO-17285] - Missing null reference check for terminal update placement when loading the game can cause loading disruption

New Feature

  • [ACEO-17323] - Autosave slider implemented to allow for custom autosave intervals

Im getting this error when I try to load ACEO via steam or desktop (Experimental Branch). It was just working a few hours ago and I haven’t done anything different other than create a few GA aircraft Mods since I last opened it. Any help on how to solve this?

Do you think this might have to do with the 32.12-1 update?

I am going to try opening the non-experimental branch version and see what happens…

Update: I am able to load the Non-experimental Branch version 32.12-0. @Olof.


Yeah, seems that Steam has somehow emptied the experimental depot over night. Investigating now…

1 Like

Just got the latest experimental update and now Steam is saying no exe, checked the game folder and its gone. Tried both verify and a full reinstall and still no exe is showing up.