Auto flight planner - bug or not?

Referring to this, quite old, topic:

But my flight planner works (always!) in a different way:

My initial setup (M) was like this, time spread is set to 120min. auto-planner has scheduled one flight (stripe) correctly, but the other one (skyLink) with a spread of 135 mins, instead of 120 mins.

This to be done all over my flight planner, after a while leads to planning setups, which are completely mixed up and I can not control my runways’ workload in any way. Which, obiously, leads to delays, chaos about turnaround handling, a.s.o.

Am I doing anything wrong? Is there any solution? Or is this a know issue? And if so, how do you handle this?

I’ve had the same before. My impression was that it could either happen due to not enough flights offered regular delays which would make the flight planner change the gap, but I couldn’t tell for sure. At least in the past it happened more on some stands than on others.
In my latest game with lots of contracts the whole planner is packed with not much more than the minimum gap (sometimes it can be a little bit more though).

OK, seems as if vanilla airlines only, are not providing enough large flights for my 16 stands… :frowning:
Let’s see if adding airline mods helps…

So you do not have night flights? ´Cause even small discrepancies, on the long run, build up, so finally nothing fits together as planned, anymore… At least at my airport…
Or do you manually adjust, from time to time?

I have night flights and never manually adjust because I’m just too lazy to care about the flight planner manually (at least as long as flights can only be scheduled for a few days and not long term).
But I have several mods enabled.
Still not sure about the reason, it might also be that I’m just lucky and in the next game it’s all mixed again.

1 Like

Intersting, thanks.

Seems as if it’s another issue, not allowing me to to use runways’ maximum capacity…
I’m curios (and a little bit worried), how planned “maximum runway capacity” will affect these things…

Edit: Nevertheless, it seems to be a bug, as I understood the idea how auto-planner is meant to work…

My flights are always over lapping when put on auto planner. For some reason the dev were asking me I did to the gane. Lol how am supposed to know when am not a dev. So I stop reporting the bug. I just cancel flights or manually. I hope other people report it because I will hurt the game soon enough. Now I make little to no suggestions or comments in the forum because of this.

I would keep reporting it. If it’s a problem for you then it’s highly possible it’s a problem for someone else. I assume you would’ve already done this but… Have you tried reinstalling the game? Creating a new save file and then testing the auto planner? Testing both the default and experimental branches?

What?

No, keep reporting it. They like it. It might not have been fixed yet because they need more information (= bug reports)

1 Like

About 1,5 years ago, I decided for myself, that flight planner is not sufficient, to fulfil my needs.

Several Versions later, there, in fact, has obviously been no improvement - but devs took away tools for planning manually, as discussed here.

For understanding, here my latest experiences:

Wednesday: Setup for auto-planner: first 2 flights per stand planned
less than 50% of all first auto-planned flights, planned correctly.
2 flights are planned with same timeslot

Thursday:
no more flights at the same time, luckily, but planned schedule is only hardly visible

Friday:
It is obvious, that flight planner won’t plan according to initial, wanted schedule, that’s why deactivated.

About the same here. I don’t trust it and there are not many controls for it. I like to, as you do, don’t align all flight to the same start times. The auto-planner should use individual gaps for each stand, have parameters what flights to prefer (by airline, price, etc).
So I plan manually with that rotten flight-planner UI that got a bit better with the filters but is still far from being perfect or even useful.

2 Likes

UPDATE:
As expected, instead of keeping initial schedule, after a while it looks that way:

Interestingly it’s working quite well, after a while.
pros:

  • flights are spreaded all over the day
  • I do only have short and resolving jams for departure flights
  • Annoying manual planning is obsolete

cons:

  • it’s very unefficient, as there could be planned several more flights, if set spread time (here 90mins) would be used consequently
  • sometimes up to three (!) flights are planned for same arrival time for same runway - how should that work ??
  • I can not set individual gaps or set preferences (as @Titule mentioned)
  • flight planner looks messys (I’m a little bit “Monk-isch”, sometimes)