Block impossible to remove


#1

Hi,

I had a problem yesterday, was impossible to destroy/build/anything on one taxyway foundation on my map.
Tried everything, reload, F10 menu, etc. The only way I got to remove the taxyway was editing the StructureData.json on the save folder.

I searched for “hasBeenBuilt”:false, since was the only thing not built on my save and removed this:

{"referenceID":"28158621-8da7-4e5e-95fc-31a86ceb125a","position":{"x":532.5,"y":472.5,"z":0.0},"rotation":{"x":0.0,"y":0.0,"z":0.0,"w":1.0},"objectName":"Taxiway Foundation","variationIndex":0,"objectSize":0,"objectQuality":0,"isFixedObject":false,"isPlaced":true,"isActivated":false,"shouldBeActivated":false,"isOperated":false,"isNotPlacedByPlayer":false,"isInside":false,"hasCreatedJobTasks":false,"timeToRegenerateJobTasksString":"0001-01-01 00:00","nbrOfStationedEmployees":1,"isBuilt":false,"hasBeenBuilt":false,"isMarkedForDemolish":false,"constructionInProgress":false,"deconstructionInProgress":true,"constructionEnergyAdded":10.0,"condition":1.0,"isBroken":false,"isBeingRepaired":false,"cleanliness":1.0,"requiresMatchingBaseSprite":false,"colors":[],"structureType":1,"taxiwayType":1}

After I removed this the highlander block disappeared.

I think this block stuck when I started to build and saved/loaded to fix the pathway problem of the airplanes.


#2

@Olof weird bug.


#3

Tried to find these files just for playing around and couldn’t locate any of the game files, even the save game files… I run it through Steam.


#4

%appdata%\Apoapsis Studios\Airport CEO\Saves\


#5

I’ve had a similar bug where if you vertically placed a fence into the 1x1 buffer zone adjacent to the map boundary, you couldn’t remove it but it would remove itself when you reloaded the game.