Invisible Modded Fuselages

Hi. I am having a problem that I have had since Beta 8. Modded aircraft fuselages are invisible. I double checked that the mod is up-to-date, but I cannot figure out why aircraft will load as invisible. It seems to be concentrated to mostly medium aircraft, and it is over a variety of mods. Has anyone encountered this, and have a remedy? It does not affect gameplay, but looks sad. I seemed to be brushed off on this topic, but any help would be greatly appreciated. I would love to not have to rebuild an airport with a new game file…

When I ran into the same issue, I had to reinstall the game.

I’ve done that, and it did not remedy…

Does it affect all mods or only specific ones? Single mods or modpacks?

I had the same issue for the longest and reinstalling the game didn’t fix anything. So I had to go into each individual modded airline/plane file, open an image editor(mine is gimp)and copy and paste the old png onto the newer mdk files and then my problems were fixed.

Yeah would be interesting to know which mods. For example if it’s the American Airlines mod from @dawed I don’t expect such issues. :confused: But there are others, sometimes very old ones on the Workshop.

It is the @dawed AA version. But it’s not just that mod.

how is the png looking in the downloadfolder of the mod? and what happen when you vopy a mod from there to your native mods?

i remember i had it once on beta 8 i guess, but only some planes…

The PNG looks like I am used to. I also compared the JSON file with a working, same aircraft from another mod, and there are no variances. So, it’s not like the textures are lining up incorrectly or something to that effect.

@Olof or anyone else? I just uninstalled the game, restarted my system, and some mods still come up invisible. :frowning: I am willing to try anything.

Do you play on Windows or Mac?

Windows 10

Have you tried cancelling the contracts and renewing after a save/load cycles?

Yes, this even happens on new, signed contracts. From the image below, the aircraft shadows are A320, A321, CR7, Cessna208, ATRs. Various airlines/mods.

Even emergency flights for airlines whose contracts I have not accepted will generate with invisible fuselages. Happened on a B1900 too.

What happens if you try a different resolution?

Nothing.

Unfortunately no-one else seems to have this issue so it must be related to your device and it’s really difficult for us to understand what the problem could be… :frowning:

I’d try a complete reinstall removing all folders of Airport CEO and Apoapsis Studios, graphics drivers update and then just trying that single mod afterwards to see if its still faulty.