Issue starting the game

I get an error message during the loading process when starting new game and saved game and then im back at the steam page again. I have uninstalled and installed the game again but still same issue. I basically can’t play the game at the moment.

I tried going from experimental to default also but same issue everywhere

What are your hardware specs?

Not very strong machine but has worked very well untill now. AMD A9-9420 Radeon R5, 4gb RAM, 64 bit

Are you sure you’re utilizing the full amount of VRAM? It sounds like you’re not running on the full specs as ACEO requires at least 2 GB of dedicated VRAM to run stable.

I have changed it but this game is the only game that I play that doesn’t work on steam.

What does the error message say? Do you get any type of crash log?

Please also try the following solutions: https://www.airportceo.com/bugs

The local files are verified and I found a crash report. Shall I click on where it say crash report and send what is in there to you? The error is a picture of a plane with red mark in løeft corner and it says Unity with a lot of letters and numbers behibd it

Yeah sure, send it to support@airportceo.com.

Exact same problem. But unable to find crash report.

My PC (Laptop) spec is i5-460m, 4gb RAM, hd5470 1gb. Does my VRAM is the limiting factor to it?

Also I found out it always crash when loading bussiness recources at 73 or 74/100 something.

Well I’d suspect that at least, at 1 GB dedicated VRAM we cannot guarantee a stable experince as per the game’s system requirements.