Loading an old save


#1

Just loaded an old save (last save date June 2018) in version 30 and it doesn’t seem to understand the old medium stands and converted them all to small stands:

On it’s own not a problem, but the issue is I cannot reconnect the taxiway path :cry: Tried everything to get the taxiway foundation connected again, but also no luck, as long as the planes are on the stands it’s not possible to do anything, so not close it, not delete it, etc. @Olof Is there a trick way to just make the planes disappear? :thinking: Looked at all the options in the F10 menu, but nothing seems to be working…


#2

Oh, I’m so pleased to hear you have this issue too. I’m not going mad (well maybe I am but that’s another story) I had exactly the same issue. Olof is aware of this so it seems to be more than just my peculiarities :slight_smile:


#3

Can you check what the string variable of the save’s version number is? It should be located in GameData.json of the save folder and the variable name is “currentGameVersion”.


#4

I only have a GameData.json but have found the variable:

“currentGameVersion”:“Alpha 30.0-0”

Do you need more info from that line, as it is part of ‘airportData’ as it looks.


#5

Looks like you’ve made a save on that game then? It overwrites that variable with the version of the game you’re running, so I’d need to see the variable value before you’re launching the save with Alpha 30… :stuck_out_tongue:


#6

Ah, ok… In this case I did a save over the old save… :frowning:

But I remembered that at some point I zipped the save to sent it to you guys and I still had that zip file :slight_smile:

Variable data from that version: “currentGameVersion”:“Alpha 27.8-3”


#7

Hmm… well, it should definitely work then. Do you remember where you sent it or the title of that e-mail? Or if you possible could send it again? :heart_eyes:


#8

Yups, no prob. Mail send on 2 Nov 2018, at 17:59 and send now again :wink:

Note to self, not overwrite an old save :relaxed:


#9

Mine was 27 as well. I’ll confirm that actual number shortly.

EDIT: 27.3.3


#10

Have investigated this issue now, unfortunately we cannot provide a fix. It’s working as intended, however the stands used and old variable for saving size and not the correct one. That variable was removed several versions ago so the one way to fix this issue is to by yourself edit those save files, i.e. change the “objectSize” variable for the serialized stands to “1” (which is the Enum value for medium). While you could make estimations from the other values in the serialized stand I don’t want to put in a lot of custom code for this particular issue, looking at the backlog we don’t have too many reports on it.


closed #11

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.