My calendar setting prevents the game from launching

Passengers do not exit cars and planes. This error appears.I deleted the game and Download it again, and it is still the same problem, and I worked for a new airport and the same problem. I uploaded a file saved from Steam workshop and still the same problem!

1 Like

Wow, that’s a weird bug! So this does not only happen on this save but on all of your saves?

1 Like

Hello mejo,

welcome to the community.

Looks like you’re not using the common calendar.
Switch to gregorian and check if that solves your problem.


Hey Scav, what do you mean by “common calender”? And where could I “switch” the used calender?

1 Like

Thanks for the answers.

Yes, I worked with two new airports and it is still the same problem. I changed the Gregorian calendar and the problem was not solved

Very strange.
Can you check if date/time in your bios is correct ? Eventually your cmos battery is bad and needs to be replaced.

Hi, I changed the battery and still the same problem

I think there is a problem with the Passenger service agent They do not work in their Check-In .

This is a very strange issue, nothing in the game is going to work unless your time measurement system is working correctly. Can you file a bug report with this save loaded?

1 Like

Your second screenshot also confuses me a bit.

Are you working with active baggage system or is that disabled?

If you work with an active system, you don’t need the small check in desks as they can’t accept baggage. But the automated baggage drop offs need ticket kiosks.

I don’t know if baggage system It works or not There is no passenger

I made a new small airport and it’s still the same problem after changing the battery and the calendar

I made bug report in game Thanks for help

Hey mejo,

if you’re using Windows 10, can you post a screenshot of the following tab, please ? :
Control Panel (view by : Large icons) then click Region.
Now go to Additional Settings and choose the Date tab.

hi i use Windows 8

No problem, it’s pretty much the same.

So, this doesn’t look like the gregorian calendar.
First day of week should be monday.
I can’t read the text in the calendar type box, I suppose that’s hijri ?
It should be gregorian. It’s used in most of the world, and probably necessary to run Airport CEO.

Finally the game is working now

First, I changed the language of my pc

Secondly, it was the English calendar, but i changed the beginning of the week from Sunday to Monday

I don’t know why this game needs a calendar. It will cause a problem for some people

Thank you guys for the help

It looks like the game is relying on your system’s local calendar’s definition for how to present times and dates, but something about the game time doesn’t map into your calendar’s definition. I don’t think it was your cmos (unless your system clock was incorrect after a reboot, too) or the system language.

It looks like .NET’s implementation (I don’t know what the game is written in, but it’s probably the same set of rules) of that calendar System.globalization.UmAlQuraCalendar only supports dates between 1900 and 2077 (Gregorian) or 1318 and 1450 (Um Al Qura). I’m guessing the game is using setYear(1) and that doesn’t map into the Um Al Qura calendar.

In the meantime, if it is an acceptable solution, it looks like you could set your local calendar to the Hijri Calendar, at least until game year 9666. At that point, you can play 333 more years with the Gregorian calendar which will fail after 9999.

If I’m right and understanding the calendar limitations correctly, those using the Hebrew (5343-5999), Korean (2334-12332) though it runs from Gregorian 1, so it might work), or ThaiBuddhist (544-10542) may run into similar problems.

Finally, it looks like there are no passengers because it can’t fill out the ticket the passenger is carrying which has a call toShortDateString()

1 Like

We’ve never seen the issue before, ever, so it’s extremely, extremely rare. That said I agree that it’s not a good solution that the .NET DateTime implementation relies so heavily on system defaults, we we’re of the assumption that in terms of DateTime we were working in a fully sealed-off environment. We’ll definitely take a look at this and make sure that we define what calendar we use “in the game’s backend”.


As a result of this we actually found a weird legacy call to the system’s current year date, which is the culprit of this problem. Our time system is in fact sealed off, but we had a line that for some unknown reason (stupid legacy code) prompted the system for its time. This is now removed and will be part of the Alpha 36 release.


This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.