Staff not moving anymore

I have tried to move my security a bit more back, so I’d have space to extend the check-in area.
I close the checkpoint and then delete it (after I’ve made sure the other checkpoints are operating and staffed). I have 3 times as much security staff as needed, but yet nobody is going to man the new checkpoints after a few minutes.
The rest of my staff also becomes idle and no longer moves.
At this point, there’s only 1 security checkpoint operational, which is creating huge jams. All security checkpoints are zoned the right way. What am I missing?
I’ve tried extending my staff room and replacing it with a bigger one, yet they are unwilling to move.

There is a weird bug which requires to save and close the game. After a restart of the game, everything moves again.

1 Like

This was not the case. After several saves & close (even closed Steam as well), staff was still stuck. Unfortunately, I had to start over.

Maybe try pressing F12 to open the bug testing menu. Then press the button to de-spawn all people or staff from the airport. That should fix it unless it is a reoccurring bug which most of the time it isn’t.

I think that button has been removed…

Yup. Maybe try pressing the button to reset the paths for the staff and pax.

Can you bug report this and get back to me here with the number?

Just send in a bug with non moving security staff.

1 Like

In case this happens in beta 5, I have the same issue. I just wanted to reproduce before bugreport but didn’t have the chance yet.

1 Like

Did some tests here, can anyone confirm if this happens when you reload a save from in-game? Or is it more random?

I have found that sometime reloading a save, is not working in one go, but is in two tries. I have to find out over time, but I think its not the only cause.

When I reload the save I normally quit to main menu and then load it again - then my problem stays. I have now quit the full game and reloaded from Steam, and my issue didn’t appear anymore. Not sure if that’s the cause.

This bug happens quite often for me as well. It totally stops the movement of some of my pax although others can go the same path. I think it’s a pretty big issue to look into. Mostly solved after re-loading a save game but it happens all to often.

Yeah, since days I try to figure out how to reproduce this.

I think it has a relation to performance and what you do in the airport.

In my case, the airport runs very smooth unless I start some construction on a different part of the map. Mainly when it involves taxiways and paths have to be recalculated.

This can cause mainly that my passengers get stuck at the boarding desk for remote gates.
They are between desk and bus and then, the boarding cannot close.
In rare cases, staff does not take up jobs.

The problem I have is just with security. Had a half built airport that was working the built some more gates etc and suddenley security will not operate. Staff are there but no doing anything. So started a new airport and security staff are not going to the checkpoints, so game currently not playable.

Have you tried just an ingame reload or did you closed the whole game before you started the map again? In most cases after this workaround, staff was moving again.

I have reloaded the game and the security checkpoints are operating now, very strange.

1 Like

I may be having this issue too. I’ve been expanding my airport and sooner or later it always happen the same thing: security checkpoints stop working, passengers won’t move, passenger service agents don’t go to the gates.

Closing and reloading doesn’t solve it. I have to close the game and steam and go back to a previous save file.

1 Like

Try loading the same game in twice, it helped for me. Make a resave in between.

Yes it happens at random usually when you do construction to terminals and sometimes airside operations like taxiways and stands.