Airport CEO Alpha 30 Released


Sounds indeed like the shops, and can only be disabled via a bug fix! :stuck_out_tongue:

1 Like

Should this happen…
Gamecrashing at random halfway through building a new part of my airport?

Anyway: nice addition that soundtrack.


Did you get some sort of a crash log?


Where should i look?

Thanks for replying


All right, we’re back from the short hiatus with the top two critical fixes for the experimental branch! We’re running several different branches now with different projects on each, so it’s getting a bit crowded.

I’ll try to explain here: A new, intended for the default branch, Alpha 29 version has been created, i.e. Alpha 29.12-11, which has these important vehicle and security queue fixes mentioned earlier. It’s deployed on a separate branch for safe-keeping while we’re awaiting the reports from the experimental branch. Alpha 30.0-1, deployed on the experimental branch, contains the same fixes that Alpha 29.12-11 has on top of all the new Alpha 30 stuff.

I believe these two fixes to be absolute, i.e. Alpha 29.12-11 will with a 99 percent certainty be deployed to the default branch tomorrow. Meanwhile, we’ll begin to properly patch Alpha 30 with all the audio related issues mentioned continuously for the rest week (i.e. daily updates are back).

… as if this wasn’t enough, we’ll tomorrow begin testing the new interactive tutorial panel on the internal branch!

I hope this made any sense, just wanted to let you all know what is going on. Here’s the changelog for Alpha 30.0-1 (and Alpha 29.12-11):

    Release notes - Airport CEO - Version Alpha 30.0-1 (Alpha 29.12-11)


  • [ACEO-11442] - Service vehicles can in certain instances deadlock when overtaking
  • [ACEO-11535] - Missing serialization of attempted target position for fetching security check-points causes persons to ignore certain check-points upon load
  • [ACEO-11592] - Service vehicles attempting to park at parking objects with already assigned vehicle of same type does not clear their assignment
  • [ACEO-11593] - Vehicle trailers do no occupy nodes

Never mind, I found your issue, seems to be audio related, will keep a lookout for it and see if there’s a solution. Should be a very, very rare type of crash.

1 Like

Did only happen onetime after 45 minutes or so, so no big deal.

1 Like

Getting this now? Can’t get into game to report :slight_smile:




I’m getting unity crash when starting the game


I’m going to guess at a bad Windows deployment. Just tried here on my Mac and loaded as it should.


It shouldn’t Always be the Apple boys who crash :smile:


Yeah, another bad deployment, those happen from time to time but more frequently when we change game engine version which we did recently due to a very minor security patch.

Uploading again now, same version! :slight_smile:


Steam downloaded again (97Mb) and same is still happening, same crash, same error :wink:


Yeah, hold on for a while, will update here when it’s working, will do a few pushes now.


All right, there we go, verified on both Windows and macOS!


Works! :slight_smile:

1 Like

Works again :smiley: :airplane::flight_arrival::flight_departure:

1 Like

A lot of ingame day’s later there hasen’t been any A321 available in the flight planer?


Really? They are a little on the rare side I agree. What does you flight selector look like in the top right corner of the flight planner? Did you cancel and renews the contracts for those that offer the A321 as well?

1 Like

All good now! thx :slight_smile:

1 Like