Corrupted save game?

#1

Hi,
while working on my new airport I couldn’t find my saved game, and later I spottet it at the bottom of the saved files with no info about timestamp. Trying to load it never leaves loading page, even if music starts and it is somehow alive (I can also find a new item that I built, look at the screenshot it is stand R11)

#2

Can you locate the output_log file? Instructions here:

Follow below instructions to locate the files.

On Windows:

  • Output log: …\Steam\SteamApps\common\Airport CEO\Airport CEO_Datafiles\output_log.txt

If you cannot find the output_log file , try this location:

  • C:\Users[YOUR USER]\AppData\LocalLow\Apoapsis Studios\Airport CEO\output_log.txt
#3

No in both locations :frowning:
I have found the savefile, all with correct timestamp into the data system folder (00:03 30/04/2019), I have a previous save (different save name 4 hrs before) that is working, would it be useful to compare the files?

Additional info: no mods, 48 stands but I don’t think is a loading issue, I can load savegame with 44 stands in less than a minute. That missing info about timestamp save really scares me :frowning:

#4

Here is download link:

#5

Manually modified “save” file adding timestamp and now it is sorted correctly, but still same result in loading “done” but stuck as in the screenshot above

#6

What game version are you playing on?

#7

30.1.9

Maybe I got it: replaced “rooms” file with the one of the previous save, and it loaded! Weird thing is that I had no rooms built, so the load I get is 100% same of what I expected it to be
Am I risking future problems of consistency? The loading got stuck on rooms section only I guess, everything else seems fine

#8

Well, each save is made new, so probably not. I know we’ve had save issues relating to variables sotred in the flight models, but very rarely in the room model. Was this an old save you loaded or brand new? Most likely a null reference issue was thrown somewhere preventing the load, but rooms should be very stable at this point.

1 Like
#9

@Olof Travolta had a quite similar issue last weekend. His savefile was corrupted, and the problem seemed to be related to his building contractors. Just in case you’ve missed it: :face_with_monocle:

2 Likes
#10

Now everything seems fine for me, anyway thanks for the impressive quick support!

1 Like
#11

Corrupt saves are rare these days so I have indeed missed it, but we’ll definitely keep a look out once the new experimental test cycle begins. The changes coming are so fundamental so it doesn’t make much sense to look at rare occurring bugs at this point.

Good to hear, and thanks, sometimes we get it right! :slight_smile:

1 Like
closed #12

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.