[Solved] Mac OS X High Sierra 10.13.6 Render Issue


#41

Will fire it up and test it first to see what happens ‘out of the box’, will ping you to test on the new branch


#42

Okay, specs as follows

Mid 2010 17" MBP
2.66GHz Core i7
8GB RAM
Video GeForce GT330M 512MB
Intel HD Graphics 288MB

Let me know as well.


#43

Can confirm that after starting up the game and deploying the contractors they do not appear


#44

On the separated internal branch and still have the same issue when starting a new game and also when starting a save game.


#45

Good!

Not good… we’ll continue investigations.


#46

Same here on default. Construction boxes as well.

EDIT: Same as Puma on sep internal too :(.


#47

New version is up!


#48

Welcome back :slight_smile:


#49

Testing now, and… they’re back :+1: :champagne: :partying_face:

But…


The building ‘packages’ are not rendered, @Rubble can you confirm that?

Also not all characters are rendered correct, some are coloured and some are not. Looks like if some of them appear to be outside or inside, while they are both in the same environment:


Notice the dark or coloured characters

ACEO graphic settings:
Resolution: 1440 x 900
Graphics: Fast

Will try on other settings if there is a difference


#50

Yes, the next update (soon) hopefully will sort that issue. Fredrik know what the issue is now.


#51

ACEO graphic settings:
Resolution: 1440 x 900
Graphics: Good

Same result.

Also noticed that all type of staff is shown except the executive staff…


Have created different staff rooms and as you can see all are filled with staff except the lower right room that is only for executives. They are also nowhere else on the map, CEO is also not in her/his room


#52

hmmm, I got the CEO.


#53

Testing now with the new update

LOL the executives only arrive by bus… :joy: They refuse to travel by underground :sunglasses:

So have all characters now


#54

Thanks for helping us out! New version will come soon with assets and boxes hopefully working as well. :slight_smile:

Edit: Not sure how well we make it visually same as current version since the problem lies with graphics card being older than 2010. These old cards do not supporting various performance enhancing techniques used to render passengers and assets.


#55

Construction boxes are back :slight_smile:


#56

Alpha 29.12-9 includes this fix so we can all switch back to the experimental branch now! Massive thanks to @Rubble and @Puma for testing it out and helping us! :heart_eyes: :heart_eyes: :heart_eyes: :heart_eyes:

I’d like to point out what Fredrik said, running the game with a graphics device that only supports Open GL 4.0 (and most likely DirectX 9.0) will have noticeably worse performance when it comes to rendering large amounts of passengers as opposed to more modern cards. So machines built around and before 2010-2012 are in the danger zone.

Locking this thread now as the issue is solved and further issues should be handled in a new thread if one arises.


[Solved] People rendering (again)
closed #57