Unable to create new game [solved]

I’m currently unable to start a new game because whenever I try, the game will crash, but it gives the Unity error window. This happened to me like twice before, so I tried to uninstall and reinstall the game but that didn’t work. I’m on the experimental branch if that means anything. It gives the screen whenever it gets to “loading businesses”. It generally crashes at 109/124 businesses loaded.

Hi

Do you play with mods?

1 Like

I would ask the same question… and if so is the case, try uninstalling all of them and see if it launches then! :slight_smile:

Yes, i play with mods. I’ll try uninstalling and then reinstalling.

Ok, so I uninstalled all mods and fired up the game. It works. I want to play with mods though, so what do I do next?

Maybe some mods are corrupt/incompatible. Try at first one mod and then add the next, so then you can find the corrupt/incompatible mod.
I play with about 15-20 active mods and having no problems. When activating too much mods it takes a lot of time to load the savegame.

I would guess you used a big modpack. Those are often outdated and some even broken.
Use single mods of airlines you really want.

Also check the date of the last update on the Workshop. If there was no update since November 2019, search for a newer entry.

I enabled only a few this time, and the mods seem to be recent. The weird thing was the mods were always enabled before and it never crashed. Anyway, I think I’ve got it figured out.

2 Likes