Airport CEO Alpha 32 Released (The Turnaround Update)

  • I just saw 18 people stuff themselves in a taxi. I thought that was fixed :thinking:
  • I think I saw the old save prompt pop up when I quit the game.

EDIT 01:

Default Alpha 32.12-0

1 Like

@EvanTheCEO, did you create a bug report of that? Sounds like an exception was thrown and I need to see the log file for that one.

@Jas, I need to check out your save files. Both you and @fabiopinto can send them immediately to us at support@airportceom.com! :slight_smile:

The taxi problem is obviously not fixed, needs more unforgiving code…

1 Like

lol good luck! :smiley:

1 Like

I’ve found the issue for the loading problem. An update will be out on the experimental branch later tonight!

2 Likes

Would this fix my issue? Fingers crossed

Sorry, update is pushed until tomorrow.

1 Like

Olof, has the update been pushed

not yet so i think devs are busy but i am sure they will push out the update

2 Likes

Good evening! A bit delayed, but here’s this weeks update for Alpha 32 on the experimental branch. We’ve fix a few critical loading problems and have added additional logging for a few save problems we’re detecting via the bug reporting tool, the extended logging is basically the game saving and including the logs of your three last plays on that specific save so that we can see what happened to your game when you saved it (today we only get the log from the current session).

We’ve also added an interval for auto saving and made it game time agnostic, so that if you build on pause the game will not finally auto save as expected! :slight_smile:

    Release notes - Airport CEO - Version Alpha 32.12-1

Improvement

  • [ACEO-17324] - Persistent logging implemented to better detect potential saving issues

Bug

  • [ACEO-17176] - Copying and pasting objects can in some instances throw null reference exceptions
  • [ACEO-17285] - Missing null reference check for terminal update placement when loading the game can cause loading disruption

New Feature

  • [ACEO-17323] - Autosave slider implemented to allow for custom autosave intervals
5 Likes

Im getting this error when I try to load ACEO via steam or desktop (Experimental Branch). It was just working a few hours ago and I haven’t done anything different other than create a few GA aircraft Mods since I last opened it. Any help on how to solve this?

Do you think this might have to do with the 32.12-1 update?

I am going to try opening the non-experimental branch version and see what happens…

Update: I am able to load the Non-experimental Branch version 32.12-0. @Olof.

3 Likes

Yeah, seems that Steam has somehow emptied the experimental depot over night. Investigating now…

1 Like

Just got the latest experimental update and now Steam is saying no exe, checked the game folder and its gone. Tried both verify and a full reinstall and still no exe is showing up.

Fixed now! 32.12-1 is up and running on the experimental branch, let’s hope it stays there for awhile now… :stuck_out_tongue:

Edit: Pushed another update, just a settings file change so nothing worth mentioning.

3 Likes

After updating the game the problem continues:

Well, that’s more or less impossible. Did you reboot Steam? Otherwise go into properties and verify the game files and the update shall make its way to you!

1 Like

I restart steam, i reinstall the game, check the files and everyone is fine but it doesn’t let me open the game. Capable either because it is the experimental because the normal open

I just wanted to report an ingame bug (give it another try and see whether the 20mb limit might have been changed) but during saving the game it just crashed. Never happened before to me.

Windows event log wasn’t much helpful for me, maybe you can read more out of it (and train your German a bit):

Name der fehlerhaften Anwendung: Airport CEO.exe, Version: 2018.4.9.14116, Zeitstempel: 0x5d77752f
Name des fehlerhaften Moduls: UnityPlayer.dll, Version: 2018.4.9.14116, Zeitstempel: 0x5d777570
Ausnahmecode: 0xc0000005
Fehleroffset: 0x000000000115c764
ID des fehlerhaften Prozesses: 0xa08
Startzeit der fehlerhaften Anwendung: 0x01d56f47ab751e0d
Pfad der fehlerhaften Anwendung: H:\SteamLibrary\steamapps\common\Airport CEO\Airport CEO.exe
Pfad des fehlerhaften Moduls: H:\SteamLibrary\steamapps\common\Airport CEO\UnityPlayer.dll
Berichtskennung: d5685764-dbdc-11e9-8b8a-001a4d5e9ab8

Besides, the bugs I wanted to report (obviously don’t have a savegame of it now):

  • Traffic jams seem to be much worse in the latest version than before (haven’t played for about a week). Trucks always get stuck blocking each other at road crossings and all my flights get delayed after a short while. Unblocking all road nodes helps just for very short time.
  • To ease the traffic jam problem I removed a bit of road, but almost all trucks still continue using it even after several minutes. You can see it in the screenshot on the right side just besides the but report tool, a catering truck is on the mud track.

Not sure if this is a bug but
If the cleaning truck gets full while cleaning an airplane, rather than sending another truck the game waits until the 1st truck is empty and resends it to clean the plane which causes a huge stall overtime

Small Commercial Aircraft Contract showing up at GA Stands

I just noticed that my contracts I have for Small Commercial Aircraft are showing up as GA Aircraft. They are not in a GA Native/Steam Contract folder. They are only set up as a Commercial Aircraft for passengers.

This is happening for all small stand aircraft I add as contracts for commercial. BARON58, CESSNA182, CESSNA208, & DHC6

Here is the Small CA Stands with my Boutique Air BARON58

And here is my GA Stands with the same Boutique Air Aircraft in the lower left.

But I don’t want Boutique Air or other Small Commercial Contracts showing up as GA. Can this be fixed?

Please and thank you :slight_smile:

ISSUE # ACEO-17432 Submitted

I believe this is caused by mod settings and such should be adressed by the modders.